kubuntu 7.04 + beryl su nvidia fx5200 [HowTo]

Forum dedicato agli studenti del corso linux e a tutti gli amanti del pinguino!

Moderatore: matteo

kubuntu 7.04 + beryl su nvidia fx5200 [HowTo]

Messaggioda Michele » lun lug 16, 2007 12:59 pm

Premetto che non parlerò in questo post della diatriba tra compiz e beryl, ma avendo provato compiz, volevo vedere anche beryl...e devo dire che non è assolutamente male a spettacolarità, anche se cmq, lo attivo solo quando devo fare il fico con qualcuno... :P
dopo un po' a mio parere stufa! :roll:

Allora gran parte di questa guida è ripresa da questo sito:
http://divilinux.wordpress.com/2007/03/ ... 10-minuti/

ma visto che avevo alcune cose che non andavamo come descritto, volevo semplicemente completarla...

Lanciare:

Codice: Seleziona tutto
sudo apt-get update
sudo apt-get upgrade


Installare i driver (io già avevo il pacchetto linux-restricted-modules-* del mio kernel quindi l'ho saltato!!!):

Codice: Seleziona tutto
sudo apt-get install nvidia-glx
sudo apt-get install linux-restricted-modules-686


Per concludere l’installazione:

Codice: Seleziona tutto
sudo nvidia-xconfig


Aprire il file /etc/X11/xorg.conf,e sostutuire alla sezione “Device” “nvidia” al posto di “vesa” oppure “nv”
Codice: Seleziona tutto
sudo kate /etc/X11/xorg.conf


Riavviate xorg..e dovreste vedere il logo “nvidia” apparire a video

===========
Nvidia-settings
===========

Lanciate da terminale

Codice: Seleziona tutto
nvidia-settings


per le impostazioni offerte dai driver appena installati

Installare Beryl + Xgl

Controllate di avere il rendering attivo

Codice: Seleziona tutto
dyve@kubuntu:~$ glxinfo | grep rendering
direct rendering: Yes
dyve@kubuntu:~$


a me qui dava un po' di sbrodolate non parlava proprio di rendering, mi dava un errore tipo questo:
Codice: Seleziona tutto
Xlib: extension "GLX" missing on display ":0.0"

ho risolto nel seguente modo:

Codice: Seleziona tutto
sudo vi /etc/X11/xorg.conf

aggiungendo nella sezione Device la seguente riga:
Codice: Seleziona tutto
Option "AllowGLXWithComposite" "true"


Aggiungere i repository per Beryl:

Codice: Seleziona tutto
sudo kate /etc/apt/sources.list


Alla fine del file scrivete:

Codice: Seleziona tutto
##BERYL
deb http://ubuntu.beryl-project.org/ feisty main
deb-src http://ubuntu.beryl-project.org feisty main


Ora bisogna scaricare la chiave pubblica:

Codice: Seleziona tutto
wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -


Installare il server Xgl e Beryl

Codice: Seleziona tutto
sudo apt-get install beryl beryl-core beryl-plugins beryl-plugins-data beryl-settings beryl-manager emerald emerald-themes xserver-xgl


===============
Creare script di avvio
===============

Creare il file di testo /usr/share/xsessions/xgl.desktop e aggiungere questo codice:

Codice: Seleziona tutto
[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application


Renderlo eseguibile con:

Codice: Seleziona tutto
sudo chmod a+x /usr/share/xsessions/xgl.desktop


Creare il file /usr/bin/startxgl.sh e inserire questo codice:

Codice: Seleziona tutto
#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:fbo -accel glx:pbuffer &
sleep 4
export DISPLAY=:1
exec startkde


Renderlo eseguibile con:

Codice: Seleziona tutto
sudo chmod a+x /usr/bin/startxgl.sh


Ora riavviare xorg,e selezionare dal “kdm” la sessione “Xgl” appena creata
(io per farlo partire o lo cerco nel menuK oppure eseguo il comando che segue...)
Lanciate il “beryl-manager” da terminale o dal launcher..ed ecco a voi Beryl (anche se da configurare)

Spero che questo post, possa tornare utile a qualche temerario pinguino... :wink:
Michele
 
Messaggi: 308
Iscritto il: ven mar 17, 2006 2:14 am

Torna a Unix, Linux & reti

Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti

cron