Pagina 1 di 1

Vista non mi fa installare XP

MessaggioInviato: gio mag 29, 2008 12:40 am
da aldus
Salve,



Ho un Compaq Presario C 500EA, per una serie di motivi ho riformattato tutto con il disco di ripristino di Vista per questo computer.

Ora volevo reinstallare XP o su un altra partizione o al suo posto.



Ma stranamente non mi da modo d' installarlo



1) Ho immesso come ordine di boot nel bios prima il CD/DVD rom

del hard disk, ma quando avvio inizia a gracchiare ed a leggere da

CD ma poi carica Vista. Se premo <ctrl>+<alt>+<canc> provando diverse volte non ottengo niente.





2) Se lascio caricare Vista e poi lancio XP da CD si avvia la schermata di XP ma l'opzione "INSTALLA" e' disabilitata.





Ho inserito il CD di XP in altri computer e funziona benissimo, purtroppo ho fatto un giro in rete ma mi sembra nessuno abbia riportato questo problema



Ciao

MessaggioInviato: gio mag 29, 2008 10:15 am
da matteo
Sei sicuro che il cd di xp sia bootable e non sia rovinato?

se il cd è funzionante, al boot dovrebbe dirti qualcosa tipo 'premi un tasto per avviare da cdrom' e ti da circa 3-5 secondi; se passano allora carica dall'harddisk.

prova il cd su un altro computer.

eventualmente fattene masterizzare una copia da qualcuno.

se il cd era originale (con licenza) puoi poi chiamare microsoft che te lo cambia.

ricorda comunque che dovrai formattare il disco, quindi copiati i file importanti da qualche parte.

se hai la possibilità di distruggere tutti i dati del disco, allora prendi un cd di linux (qualsiasi) e dai dd if=/dev/zero of=/dev/hda count=1000
questo riporta il disco in stato vergine.

a seconda della distro e del tipo di disco, potresti vederlo come /dev/sda invece che /dev/hda

okkio, stacca qualsiasi disco/pendrive usb per non rischiare macelli (una volta stavo per formattare il disco usb anzichè quello del pc)


Matteo

MessaggioInviato: gio giu 05, 2008 4:28 pm
da aldus
Ciao Matteo ho risolto il problema, la copia di XP era funzionante, il problema era che il mio HD e' un SATA (Serial-ATA) quando XP e' stato sviluppato SATA non era molto diffuso e quindi i driver x riconoscerlo non sono stati implementati.
Comunque ci dovrebbero essere 2 metodi per risolverlo uno via software vedi link http://www.p2pforum.it/forum/showthread.php?t=302722

e l' altro come nel mio caso staccando un connettore del Drive SATA.

Su quello software proposto su quel sito mi sorge un dubbio, perche allora quando appena comprai il mio Compaq, riusci ad installare XP professional???

MessaggioInviato: gio giu 05, 2008 4:52 pm
da matteo
il cd che hai utilizzato a suo tempo è lo stesso che usi ora?

ci sono più versioni di xp, soprattutto quelle crakkate.
p.e., service pack 2 è uscita nella prima metà del 2004; la copia del cd di xp che avevo io era service pack 2 patchato ad agosto (sempre 2004).

in questo momento non posso vedere il link, ma il metodo ufficiale per installare su dischi sata o scsi o in generale su periferiche non riconosciute da xp, è farsi un floppy con i driver dei dischi; in fase di avvio del cdrom l'installer chiede "premere F6 per usare driver esterni su floppy" o simile... premi F6 e inserisci il floppy..
..
..
se poi è un portatile e non ha un floppy beh, allora è più complicato!!
..
..

Matteo

MessaggioInviato: gio giu 05, 2008 5:06 pm
da aldus
Si l' XP prof. +SP2 e' esattamento lo stesso Cd che installai quando comprai il computer.

Infatti, quel link da un suggerimento per chi non ha il Floppy Drive, con l' ausilio di un paio di software, rintraccia il driver x riconoscere gli Hd SATA presenti sotto Vista e l' implementa in una sorta di ISO XP.

Ciao
Aldo